Erik
Ok cool! Let me know how it goes if you do.
Wed Mar 6, 2019 12:08pm
68.194.128.14

Haven't tried to install and run on Raspian on my Pi. The deb package is a binary file with support text based dat files so not sure if it will run if the cpu arch isn't x64 (which it was compiled on).

Worth a shot though!

  • I'm still mostly Windows here...Puckdropper, Wed Feb 27 4:14am
    I wonder if the Octoprint bundle will install those packages... It's apparently running Raspbian which is based on Debian. I might have to give that a try when I get some free time.
    • Ok cool! Let me know how it goes if you do. ☻ Erik, Wed Mar 6 12:08pm
      • I'm not printingPuckdropper, Wed Mar 6 4:06pm
        so I tried it. This may not be straight Rasbian, but should be close enough. Downloaded the file, used the sudo dpkg -i file command, and it installed just fine. When I tried to run it, I get:... more
        • Compiling from source doesn't workPuckdropper, Wed Mar 6 4:16pm
          I installed opencobol sudo apt-get install opencobol then followed your compiler invoke instructions. Here's the errors: pi@octopi:~/wry-cobol-1.0.0.0/wry_cobol $ cobc -x -o bin/wry-cobol... more
          • I'm having a similar issue trying to get the Windows executable built. cobc doesn't produce the executable for some reason but, for me, also didn't throw any errors. On yours, the warning should be... more
            • Got it working...Erik , Sun Mar 17 2:58am
              Looks like the bin directory needed to be created manually before running the cobc command. Also, you'll need the data directory from either the installed deb package that won't run or through... more
Click here to receive daily updates
"Don't quote me." - Erik